Abc Assignment Help

LAN Plan and Configuration for a Business

MN621 Advanced Network Design Assignment 

Description 

A case study: Local Area Network design and configuration 

There is an organisation which is primarily e-commerce business. It is going through a major transformation because of its expansion. The expansion is due to merger of two smaller businesses to the organisation. Now, the organisation is moving to a new building having about 100 employees. The new building is of three floors. The ground floor is for reception, foyer and warehouse so there is a need of five data points at reception, four in warehouse and two in foyer. The 1. floor consists of five offices and forty open plan office cubicles. The 2n° floor consists of three rooms, each room have four office cubicles, two offices and thirty open plan cubicles. There is also a meeting room at 2' floor that requires four data points. Each and every person needs two data points at their desk whether it's an office, room cubicle or open plan cubicle. Each floor also needs wireless connectivity. 

This organisation needs a new LAN plan, design and implementation before they move to new facility. 

Description 

Design a local area network for the given case study. 

Write a report on a network plan and configurations having following sections: 

  1. Analyse the need for the network for above case study. Investigate and propose a suitable complete network design for the case study. 
  2. Write a detailed setup of network devices only for a LAN. 
  3. Write a detailed implementation report which includes configurations of each networking device which are included in the whole network. 

4. Demonstrate and compare at least 2 configuration results which may include at least two switches/routers and two PCs on physical networking devices. [20 marks] 

Demonstration: 

Students can demonstrate in a group of 2. Students should be ready with all setup and configurations before start of the laboratory class. Tutor will ask 2-3 questions to each student to demonstrate any configuration of the setup. Demonstration from each student should not be more than 3 minutes. 

Students should give their group members to tutor in week 7 during lab class. Students will get demonstration timetable before start of the week 8 lab class.

Answer

I. Project Scope

This project indicates network for a business which has about 100 employers. It includes network diagram, network plan and hardware to meet with the business requirements. It also has network configuration for network devices,

II. Project Details

3 Cisco 2960 with 48 ports will enough for 100 users for business. 

1 Cisco 4321 Integrated Services router is design to deliver advanced services to the small enterprise branch environment. 

3 AP will ensure internet connection on each floor of company

3 servers run on Win 2016 Data Center which will install AD to manage users and computer in company such as apply Group Policy for specify users or groups. DNS will help users access company services by name instead IP Address. DHCP will assign IP Address automatically to PCs which were plugged in network.

Company network will have 3 subnets and VLANs for security reasons:

  • 192.168.10.0/24 VLAN10 for ITs who has manage IT and Network system.
  • 192.168.20.0/24 VLAN20 forManagers who manage company.
  • 192.168.30.0/24 VLAN30 for Staffs who work for company.

Using VLAN will save ports on switch and in case of computers in one VLAN are been virus, however, others will be not.

III. Hardware Requirement

ManufacturerSeriesModelFeatureQuantity





Cisco





2900





Catalyst 2960
  • 24 Up to 15.4W/48 Up to 7.7W PoE Ports
  • Layer 2 Fast Ethernet Switching
  • Dual-Purpose Gigabit Ethernet Uplinks
  • Borderless Networks Architecture
  • Cisco EnergyWise Technology
  • Efficient Switch Operation
  • Intelligent Power Management
  • Superior Redundancy for Fault Backup
  • Low Network Total Cost of Ownership






3




Cisco




4000




ISR4321/K9 

  • Aggregate Throughput: 50 Mbps to 100 Mbps
  • Total onboard WAN or LAN 10/100/1000 ports: 2

  • RJ-45-based ports: 2
  • SFP-based ports: 1
  • NIM (Network Interface Modules) slots: 2



1






TP Link







TL-AP302C-PoE
  • Wireless Protocol:802.11b
Model Number:TL-AP302C-PoE
  • Standards And Protocols:802.11b 802.11g 802.11n
  • Max wireless speed :300Mbps
  • Size:190*170*30mm
  • Frequency Range:2.4GHz
  • Port :1*10/100M RJ45 port
  • power supply: PoE supply
  • Wireless Security:WPA.WPA2.WPA-PSK.WPA2-PSK
  • With Modem Function: Fat AP and Fit AP

3



TypePurposeHardwareQuantity


Server


AD + DNS + DHCP
  • Intel® Xeon® Scalable 3104 (6 core, 1.7 GHz, 8.25 MB, 85W)
  • 32GB DDR4
  • 500GB SSD
  • Win 2016 Data Center


3


PC


For users
  • Core I5
  • 4GB memory
  • 256GB HDD 7200rpm
  • Win 10


100


The organization having e-commerce business in the given case study is planning to merge two smaller businesses with the existing business. The organization needs a new wireless LAN connection for 100 employees. The new network connectivity plan will provide a wireless connection to this office. The new building where the network will be installed has three floors. Each of the floors has number of offices and cubicles each of which needs internet connectivity. It is difficult to implement wired connectivity and it also requires more time than going wireless. For this reason, planning a wireless network is suitable for this new building. The wireless network connection plan may provide the following facilities to the business:

  • The main need of having wireless connectivity is that it provides flexibility to the connectivity. As per the case study, e-commerce organization has a growing business, which means in future, the business may expand with new floors and offices. Having wireless connectivity will help the organization to implement internet connection to the new devices (Liao et al. 2017)
  • There are 100 employees in the business in the three floors. Employees from different floor, offices and cubicles can share files seamlessly with each other while having network connectivity. 
  • The proposed wireless network connectivity reduces need of number of cables and extra devices during setup. It will reduce extra cost for the organization
  • As the business is about e-commerce business, it is essential to have network connection in the office. For managing inventory, warehouse or their e-commerce website network connection is a primary requirement. 
  • As the network connection plan is about the wireless connection, it can handle large number of users rather than wired connection. Therefore, in future if the business expand and engage with more number of employees there will know the connection will be able to handle it.

The networking design needs a central internet hum, number of router and PCs for complete connection. Detailed requirement of the network devices and implementation techniques are given below. 

IV. Network Diagram1. Overall Network Model

network diagram


2. Connection between Switches and Router

switches and router


Setting up the network connection for this office is relatively straight forward. As the current network design is based on wireless connection, it can be implemented faster than wired connection. The network connection plan involves number of network devices, network design and configuration and specific implementation techniques and so on. The network devices that are needed to setup the proposed LAN connectivity are as follows: 


Router: For the wireless network set up the first requirement is a router such as D-link or TP-link router. It is recommended to use a TP-link router having wireless protocol 802.11b. The router provides network speed up to 300 Mbps. and 2.4GHz frequency range. The router provides robust network security having protocols of WPA, WPA PSK, WPA2, and WPA2-PSK.

Wire-based connections and PORTs: Although it is a wireless network connection plan, it requires some wired Ethernet ports. The ports will be used to connect the broadband modem and the routers (Ye et al. 2015).

Wireless NIC- To communicate with the router the connection needs a wireless network interface card. A laptop generally has NIC; however, for the desktops in this current office manual installation of NIC is needed. 

Wireless repeaters:  The repeater is also important network devices used to boost the connectivity. If the business grows, in future repeaters will help them to extend the network easily. It works as a range expander or a signal booster for which is useful in this case. 

Hubs: A network hub will work as a central connector of the entire router in this office (Wang et al. 2017). The routers or switches used in the different floors in the entire building will connect with the central network hub.

V. Network Device Configuration

NamePortModeConfiguration


Switch


switch#configure terminal
switch(config)#vlan 10
switch(config-vlan)#name IT
switch(config-vlan)#exit
switch(config)#vlan 20
switch(config-vlan)#name Mangager
switch(config-vlan)#exit
switch(config)#vlan 30
switch(config-vlan)#name User
switch(config-vlan)#exit
switch#show vlan brief(display vlan information)




S1

S2





F0/46





Trunk
S1#configure terminal
S1(config)#interface f0/46
S1 (config-if)#switchport trunk allow vlan 10,20,30




F0/45


Trunk
S1#configure terminal
S1(config)#interface f0/45
S1(config-if)#switchport mode trunk



F0/44
TrunkS1#configure terminal
S1(config)#interface f0/44
S1(config-if)#switchport trunk allow vlan 10,20,30

F0/0>>f0/34AccessS1#configure terminal
S1(config)#interface range f0/0-34
S`(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 30
S1(config-if-range)#no shut

F0/35>>f0/39AccessS1#configure terminal
S1(config)#interface range f0/35-39
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 20
S1(config-if-range)#no shut

F0/40>>f0/42AccessS1#configure terminal
S1(config)#interface range f0/40-42
S1(config-if-range)#switchport mode access
S1(config-if-range)#switchport access vlan 10
S1(config-if-range)#no shut




F0/46





Trunk
S2#configure terminal
S2(config)#interface f0/46
S2 (config-if)#switchport trunk allow vlan 10,20,30






F0/45





Trunk
S2#configure terminal
S2(config)#interface f0/45
S2 (config-if)#switchport trunk allow vlan 10,20,30



F0/0>>f0/34



Access
S2#configure terminal
S2(config)#interface range f0/0-34
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#no shut






F0/35>>f0/39
AccessS2#configure terminal
S2(config)#interface range f0/35-39
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#no shut





F0/40>>f0/42




Access
S2#configure terminal
S2(config)#interface range f0/40-42
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#no shut




F0/46





Trunk
S3#configure terminal
S3(config)#interface f0/46
S3 (config-if)#switchport trunk allow vlan 10,20,30






S3



F0/45





Trunk
S3#configure terminal
S3(config)#interface f0/45
S3 (config-if)#switchport trunk allow vlan 10,20,30



F0/0>>f0/34



Access
S3#configure terminal
S3(config)#interface range f0/0-34
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#no shut





F0/35>>f0/39




Access
S2#configure terminal
S3(config)#interface range f0/35-39
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#no shut







F0/40>>f0/42






Access


S3#configure terminal
S3(config)#interface range f0/40-42
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#no shut








R1







F0/0






















Router(config)#host R1
R1(config)#interface f0/0.10
R1(config-subif)#encapsulation dot1q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config)#interface f0/0.20
R1(config-subif)#encapsulation dot1q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config)#interface f0/0.30
R1(config-subif)#encapsulation dot1q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#interface f0/0
R1(config-if)#no shutdown








R1(config)#access list 10 permit 192.168.10.0 0.0.0.255
R1(config)#access list 20 permit 192.168.20.0 0.0.0.255
R1(config)#access list 30 permit 192.168.30.0 0.0.0.255
R1(config)#ip nat inside source list 10 interface s0/1/0 overload
R1(config)#ip nat inside source list 20 interface s0/1/0 overload
R1(config)#ip nat inside source list 30 interface s0/1/0 overload
R1(config)#interface s0/1/0
R1(config-if)#ip nat outside
R1(config)#interface f0/0.10
R1(config-if)#ip nat inside
R1(config)#interface f0/0.20
R1(config-if)#ip nat inside
R1(config)#interface f0/0.30
R1(config-if)#ip nat inside


After identifying the need network connection, coverage area and network device an implementation plan needs to be executed. The implementation plan for the wireless connectivity may consist of the following steps

Step 1: Bandwidth utilization: This step of the implementation plan involves increasing the number of APs to enhance throughput per user. For instance- ten users are connected with 802.11g LAN connection and shares 54MBs speed. Adding an extra AP will give maximum throughput to each user (Bellalta et al. 2016)

Step 2: Perform site survey: Performing a site survey will allow proper adjustment of the listed hardware requirements according to the network coverage. Especially when expanding a business and implementing networking plan for new building performing a site survey is necessary. 

Step 3: Configuration: The recommended configuration plan has the following steps: 

  • At least 100 MBps upload and download speed of each router is recommended for this office.   
  • Connecting the modem with LAN port on the router
  • Connecting the switch with the LAN port on the router
  • Connecting the ethernet port between the desktops and the routers
  • Testing the network 

Step 4: Implement security: Considering security implementation is essential to minimize unauthorized access to the network in the office (Thomas et al. 2014). Security enhancement may be achieved by turning of SSID (Service set identifier) and changing default SSID. 

Step 5: Deployment and Training: Once the network configuration and infrastructure setup is done, it is time to deploy the plan by providing training to user. The users in the office need to have proper knowledge about safe usage and appropriate utilization of the network setup. 

We need save configure to avoid losing it by issue command in enable mode:

#copy running-config startup-config

Customer Testimonials