Local Area Network For Victoria University Company

pages Pages: 4word Words: 890

Question :

LOCAL AREA NETWORK TECHNOLOGIES

Objective:

  • By completing this assignment, students will be demonstrating their knowledge and skills leant from week 1-5 that include:
    • IP address planning
    • Local Area Network technologies
    • Implement and configure Local Area Network of medium complexity in Cisco Packet Tracer

Scenario

Victoria University Company has recently restructruing and needs to develop a new local area network to meet business requirements. You are hired by the company to design and build the network.

The initial phase involves design and development of a network for a number of building as shown in the below map.

 Design and Development of a Network

The physical organization is as follows:

  • Building L hosts Sport and Health Departments
  • Building M hosts Sport and Health Departments
  • Building G hosts Business and Engineering Departments
  • Building A hosts Human Resources and Business Departments

The network requirement of each department is detailed as follow:

Sport
Number of employee
100
Each employee has
01 PC + 01 IP Phone
The department has
1 server
Health
Number of employee
50
Each employee has
01 PC + 01 IP Phone
The department has
1 server
Business
Number of employee
50
Each employee has
01 PC + 01 IP Phone
The department has
1 server
Engineering
Number of employee
30
Each employee has
01 PC + 01 IP Phone
The department has
1 server
Human Resources
Number of employee
10
Each employee has
01 PC + 01 IP Phone
The department has
2 servers

After discussing with the company leaders and their technical staff, both sides have agreed with the following technical requirements:

  • Each department should be placed on a separate SUBNET for management.
  • Departments located within the same building should use the same Layer-2 switches. VLAN must be used to separate traffics between departments.
  • Layer-3 switches must be used for routing between VLANs of the internal networks.
  • The network should be designed with high performance and high availability requirements using Ether channel and First Hop Redundancy technologies.

address of internal network.

  • The network should be designed to optimize the cost i.e. you should try to use least numbers of network devices and links.
  • The company was assigned the following IP address range to use for their networks: 172.XY.0.0/16 (XY is the last 2 digits of your student ID)

Specific Assignment Requirement

To complete this assignment, you are recommended to take the steps below:

  1. Design and draw network topology using packet tracers (or other drawing tools). Clearly label the buildings, departments, switches and router.
  2. Identify how many subnets are required for your proposed topology. Design the subnets based on the given network address (172.XY.0.0/16) to optimize the address spaces (using the second approach  number of hosts needed). Note: the link between the gateway router of the university and ISP router has been assigned with network 200.1.X.0/24 (X is the first digits of your student ID).

Create a table and provide details of the network design for each network such as below:

Sport
Allocated subnet/Mask

Network address

Default gateway address

Valid host address range

Broadcast address

Label the drawn network topology with corresponding subnets and ip addresses and then take screenshot the proposed network. Where necessary, our configuration design should account for VLAN, Routing, NAT, and Redundancy.

Place configuration of each device into a table as below:

S1
(Please type the script here as below, NOT using screenshot from packet tracer)
S1: enable
S1: configure terminal S1:. . .


Then, enter the script into packet tracer to implement a functional network. (50 marks)

5. Perform necessary verification to test the performance of the proposed network. All computers should be able to ping to any other computers on different networks and to the port on router. If either of the Layer 3 switches fails, the network should still be functional.

Use necessary screenshots of ping and show commands on computers, switches and routers to show the status and performance of your network. (15 marks)

Show More

Answer :

Network topology


Network topology

Subnets requirement

Sport
Allocated subnet/Mask/24
Network address172.16.0.0
Default gateway address172.16.0.1
Valid host address range172.16.0.1 - 172.16.0.254
Broadcast address172.16.0.255


Health
Allocated subnet/Mask/25
Network address172.16.1.0
Default gateway address172.16.1.1
Valid host address range172.16.1.1 - 172.16.1.126
Broadcast address172.16.1.127


Business
Allocated subnet/Mask/25
Network address172.16.1.128
Default gateway address172.16.1.129
Valid host address range172.16.1.129 - 172.16.1.254
Broadcast address172.16.1.255


Engineer
Allocated subnet/Mask/26
Network address172.16.2.0
Default gateway address172.16.2.1
Valid host address range172.16.2.1 - 172.16.2.62
Broadcast address172.16.2.63


Human Resources
Allocated subnet/Mask/27
Network address172.16.2.64
Default gateway address172.16.2.65
Valid host address range172.16.2.65 - 172.16.2.94
Broadcast address172.16.2.95


Network topology screenshot from Packet tracer



Network topology screenshot from Packet tracer

Device Configuration


Switch L configuration 

enable

config t

hostname switch-L

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex

int fa 0/23

switchport access vlan 100

ex

int fa 0/24

switchport access vlan 101

ex


int fa 0/10

switchport mode trunk

ex

int fa 0/11

switchport mode trunk

ex

Switch M configuration 

enable

config t

hostname switch-M

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex

int fa 0/23

switchport access vlan 100

ex

int fa 0/24

switchport access vlan 101

ex



int fa 0/11

switchport mode trunk

ex

int fa 0/12

switchport mode trunk

ex





Switch G configuration 

enable

config t

hostname switch-G

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex


int fa 0/21

switchport mode trunk

ex

int fa 0/22

switchport mode trunk

ex






Switch A configuration 

enable

config t

hostname switch-A

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex

int fa 0/2

switchport access vlan 104

ex

int fa 0/3

switchport access vlan 102

ex

int 

int fa 0/22

switchport mode trunk

ex

int fa 0/23

switchport mode trunk

ex

Switch K configuration 

enable

config t

hostname switch-K

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex

int fa 0/2

switchport access vlan 100

ex

int fa 0/3

switchport access vlan 101

ex

int fa 0/4

switchport access vlan 102

ex

int fa 0/5

switchport access vlan 104

ex

int fa 0/6

switchport access vlan 104

ex

int fa 0/7

switchport access vlan 103

ex

int fa 0/24

switchport mode trunk

ex

int fa 0/14

switchport mode trunk

ex

Switch switch-L3-1 configuration 

enable

config t

hostname switch-L3-1

ip routing

vlan 100

name Sport

vlan 101

name Health

vlan 102

name Business

vlan 103

name Engg

vlan 104

name HR

ex


int fa 0/1

ip add 172.28.2.98 255.255.255.252

no sh

ex

int vlan 100

ip add 172.16.0.1 255.255.255.252

ex

int vlan 101

ip add 172.16.1.1 255.255.255.128

ex


int vlan 102

ip add 172.16.1.129 255.255.255.128

ex 

int vlan 103

ip add 172.16.2.1 255.255.255.192

ex


Gateway router configuration 

enable

config t

hostname Gateway


int fa 0/0

ip add 172.28.2.97 255.255.255.252

no sh

ex



int fa 0/0

ip nat inside

ex


int serial 0/0/0

ip nat outside

ex


int serial 0/0/0

ip address 200.1.1.1 255.255.255.252



access-list 100 remark NAT

access-list 100 permit ip 172.38.0.0  0.0.255.255 any


ip nat inside source list 100 interface serial 0/0/0 

overload


ip route 0.0.0.0 0.0.0.0 200.1.1.2

ISP router configuration 

enable

config t

hostname ISP

int serial 0/0/0

ip address 200.1.1.1. 255.255.255.252

ex

Verification screenshot 

Show VLAN output for switch L

Show VLAN output for switch L

Show ip interface brief output for L3 switch

Show ip interface brief output for L3 switch

Ping from sports pc to Switch L

Ping from sports pc to Switch L




Ping form Engg PC to Business PC

Ping form Engg PC to Business PC


Tags:vlan